summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2018-08-08 11:11:44 +0200
committerGuillem Jover <guillem@debian.org>2018-08-30 03:14:07 +0200
commitc3f8bca7e6cf4d75ca94dc4b92c9d7f63d23775f (patch)
tree7c739655d5fe66b2443fadfade21b041e0803ae5 /debian
parent108f8a9e0a9f7e992c4d61e202e26bb6eef6c7c6 (diff)
downloaddpkg-c3f8bca7e6cf4d75ca94dc4b92c9d7f63d23775f.tar.gz
debian: Enable verbose test suite only in non-terse builds
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index a925929d5..b129c07a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -199,6 +199,7 @@ dpkg (1.19.1) UNRELEASED; urgency=medium
- Do not pass VERBOSE to test suite, as we are not using any automake
test driver, so it does not get honored.
- Rename maintainer-build DEB_BUILD_OPTIONS to new standardized terse.
+ - Enable verbose test suite only in non-terse builds.
* Test suite:
- Skip Dpkg::OpenPGP test if gpg is not present.
- Check POD in all perl scripts.
diff --git a/debian/rules b/debian/rules
index 49812fdd2..09dc6e65e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,6 +35,7 @@ ifeq ($(DEB_HOST_ARCH_OS),linux)
endif
ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
confflags += --disable-silent-rules
+ testflags += TESTSUITEFLAGS=--verbose
endif
# Enable parallel test suite
@@ -83,8 +84,7 @@ check: build
dh_testdir
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- cd build-tree && $(MAKE) TESTSUITEFLAGS=--verbose \
- TEST_PARALLEL=$(NUMJOBS) check
+ cd build-tree && $(MAKE) $(testflags) TEST_PARALLEL=$(NUMJOBS) check
endif
# Install the package underneath debian/tmp