summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index fd2fff3..38aefa8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,8 +14,8 @@ DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
DEBVERSION := $(shell dpkg-parsechangelog | awk '/^Version: / { print $$2 }' | sed 's/^.*-//' )
-ifneq (,$(filter $(ARCH), i386 kfreebsd-i386))
- USE_THIS_GCC_VERSION:=-4.5
+ifneq (,$(filter $(ARCH), i386 kfreebsd-i386 hurd-i386))
+ USE_THIS_GCC_VERSION:=-4.4
endif
export MYSQL_BUILD_CC=$(DEB_HOST_GNU_TYPE)-gcc$(USE_THIS_GCC_VERSION)