summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
3 files changed, 5 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 3056587..6cfc9ca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,8 @@ mysql-5.5 (5.5.25+dfsg-1) UNRELEASED; urgency=low
* Fixing regular expression in tests to guard against build path containing
the '+' symbol (Closes: #674210)
- * Setting the gcc/g++ version to 4.5 on i386 platforms (cf. #674267)
+ * Setting the gcc/g++ version to 4.4 on i386 platforms (Closes: #674267)
+ but see #678252 for follow up from upstream
* Removed main_openssl_1 patch
* Set SYSTEM_TYPE according to GNU Build System
* In an effort to get a better handle on test coverage, made test failures
diff --git a/debian/control b/debian/control
index 5362f19..0808e98 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Debian MySQL Maintainers <pkg-mysql-maint@lists.alioth.debian.org>
Uploaders: Norbert Tretkowski <norbert@tretkowski.de>,
Clint Byrum <clint@ubuntu.com>, Nicholas Bamber <nicholas@periapt.co.uk>
-Build-Depends: debhelper (>= 8.1.3~), libaio-dev[linux-any], libncurses5-dev (>= 5.0-6), perl, libwrap0-dev (>= 7.6-8.3), zlib1g-dev (>= 1:1.1.3-5), libreadline-dev, po-debconf, psmisc, chrpath, gawk, bison, lsb-release, hardening-wrapper, cmake, gcc-4.5 [any-i386], g++-4.5 [any-i386]
+Build-Depends: debhelper (>= 8.1.3~), libaio-dev[linux-any], libncurses5-dev (>= 5.0-6), perl, libwrap0-dev (>= 7.6-8.3), zlib1g-dev (>= 1:1.1.3-5), libreadline-dev, po-debconf, psmisc, chrpath, gawk, bison, lsb-release, hardening-wrapper, cmake, gcc-4.4 [any-i386], g++-4.4 [any-i386]
Standards-Version: 3.9.3
Homepage: http://dev.mysql.com/
Vcs-Browser: http://svn.debian.org/wsvn/pkg-mysql/mysql-5.5/
diff --git a/debian/rules b/debian/rules
index fd2fff3..38aefa8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,8 +14,8 @@ DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
DEBVERSION := $(shell dpkg-parsechangelog | awk '/^Version: / { print $$2 }' | sed 's/^.*-//' )
-ifneq (,$(filter $(ARCH), i386 kfreebsd-i386))
- USE_THIS_GCC_VERSION:=-4.5
+ifneq (,$(filter $(ARCH), i386 kfreebsd-i386 hurd-i386))
+ USE_THIS_GCC_VERSION:=-4.4
endif
export MYSQL_BUILD_CC=$(DEB_HOST_GNU_TYPE)-gcc$(USE_THIS_GCC_VERSION)