summaryrefslogtreecommitdiff
path: root/p/haskell-unlambda/debian
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2012-11-01 20:48:21 +0400
committerClint Adams <clint@debian.org>2012-11-01 20:48:21 +0400
commit65d5092e2c932bdde289dfd812bae5d92aec543c (patch)
tree935798bc738e2e2f4c492ddcd455d55cf36d6c6e /p/haskell-unlambda/debian
parent64464fff697f88fb041bb4ab74fa8e678d50057b (diff)
downloadDHG_packages-65d5092e2c932bdde289dfd812bae5d92aec543c.tar.gz
haskell-unlambda: New upstream version 0.1.3.
Diffstat (limited to 'p/haskell-unlambda/debian')
-rw-r--r--p/haskell-unlambda/debian/changelog6
-rw-r--r--p/haskell-unlambda/debian/patches/new-exceptions.diff43
-rw-r--r--p/haskell-unlambda/debian/patches/series1
-rw-r--r--p/haskell-unlambda/debian/patches/unlambda_hs_charset_fix.diff15
4 files changed, 11 insertions, 54 deletions
diff --git a/p/haskell-unlambda/debian/changelog b/p/haskell-unlambda/debian/changelog
index 37269e3cb..43a110c36 100644
--- a/p/haskell-unlambda/debian/changelog
+++ b/p/haskell-unlambda/debian/changelog
@@ -1,3 +1,9 @@
+haskell-unlambda (0.1.3-1) UNRELEASED; urgency=low
+
+ * New upstream version.
+
+ -- Clint Adams <clint@debian.org> Thu, 01 Nov 2012 12:42:15 -0400
+
haskell-unlambda (0.1-3) experimental; urgency=low
[ Joachim Breitner ]
diff --git a/p/haskell-unlambda/debian/patches/new-exceptions.diff b/p/haskell-unlambda/debian/patches/new-exceptions.diff
deleted file mode 100644
index 4d649ffaa..000000000
--- a/p/haskell-unlambda/debian/patches/new-exceptions.diff
+++ /dev/null
@@ -1,43 +0,0 @@
-Index: haskell-unlambda-0.1/Language/Unlambda.hs
-===================================================================
---- haskell-unlambda-0.1.orig/Language/Unlambda.hs 2012-10-31 03:59:04.000000000 +0000
-+++ haskell-unlambda-0.1/Language/Unlambda.hs 2012-10-31 04:05:55.828986238 +0000
-@@ -26,6 +26,8 @@
-
- module Language.Unlambda where
-
-+import Control.Exception.Base (catch, IOException)
-+
- ------------------------------------------------------------------------
- -- Abstract syntax
-
-@@ -132,7 +134,7 @@
- apply (Dot c) x = step >> io (putChar c) >> return x
- apply E x = exit x
- apply At f = do
-- dat <- io $ catch (getChar >>= return . Just) (const $ return Nothing)
-+ dat <- io $ catch (getChar >>= return . Just) ((const $ return Nothing) :: IOException -> IO (Maybe Char))
- setCurrentChar dat
- apply f (case dat of Nothing -> V ; Just _ -> I)
- apply (Ques c) f = do
-Index: haskell-unlambda-0.1/Main.hs
-===================================================================
---- haskell-unlambda-0.1.orig/Main.hs 2008-06-08 22:40:02.000000000 +0000
-+++ haskell-unlambda-0.1/Main.hs 2012-10-31 04:09:45.976968843 +0000
-@@ -7,6 +7,7 @@
- import System.Posix.Resource
- import Data.Char
- import System.IO
-+import Control.Exception.Base (catch, IOException)
-
- import Language.Unlambda
-
-@@ -24,7 +25,7 @@
- --
- parse :: Handle -> IO Exp
- parse h = do
-- c <- catch (hGetChar h) (\_ -> error "Parse error at end of file")
-+ c <- catch (hGetChar h) ((\_ -> error "Parse error at end of file") :: IOException -> IO Char)
- case toLower c of
- d | d `elem` " \t\n" -> parse h
- '`' -> do e1 <- parse h
diff --git a/p/haskell-unlambda/debian/patches/series b/p/haskell-unlambda/debian/patches/series
index 896857cca..a1fa2adbe 100644
--- a/p/haskell-unlambda/debian/patches/series
+++ b/p/haskell-unlambda/debian/patches/series
@@ -1,2 +1 @@
unlambda_hs_charset_fix.diff
-new-exceptions.diff
diff --git a/p/haskell-unlambda/debian/patches/unlambda_hs_charset_fix.diff b/p/haskell-unlambda/debian/patches/unlambda_hs_charset_fix.diff
index 779882ce2..c8ac420d4 100644
--- a/p/haskell-unlambda/debian/patches/unlambda_hs_charset_fix.diff
+++ b/p/haskell-unlambda/debian/patches/unlambda_hs_charset_fix.diff
@@ -1,6 +1,8 @@
---- a/Language/Unlambda.hs
-+++ b/Language/Unlambda.hs
-@@ -6,7 +6,7 @@
+Index: unlambda-0.1.3/Language/Unlambda.hs
+===================================================================
+--- unlambda-0.1.3.orig/Language/Unlambda.hs 2012-10-31 12:57:28.000000000 -0400
++++ unlambda-0.1.3/Language/Unlambda.hs 2012-11-01 12:45:35.773424569 -0400
+@@ -5,7 +5,7 @@
This is an interpreter of the Unlambda language, written in
the pure, lazy, functional language Haskell.
@@ -9,10 +11,3 @@
Copyright (C) 2006 by Don Stewart - http://www.cse.unsw.edu.au/~dons
This program is free software; you can redistribute it and/or modify
-@@ -141,4 +141,4 @@
- apply Pipe f = do
- cur <- currentChar
- apply f (case cur of Nothing -> V ; Just c -> (Dot c))
--apply (App _ _) _ = error "Unknown application"
-\ No newline at end of file
-+apply (App _ _) _ = error "Unknown application"