summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2008-06-28 17:06:42 +0000
committerModestas Vainius <modestas@vainius.eu>2008-06-28 17:06:42 +0000
commit79fae09995edda95832d05f8ee67741d5ea3bd9f (patch)
tree38561fc7ad0e9144aa0b547d5c42c36548d69fd1 /debian
parente7e3c0b345eca1310872ae5153b3a2c8e1db622a (diff)
downloadqt4-x11-79fae09995edda95832d05f8ee67741d5ea3bd9f.tar.gz
Fix famous QPrintDialog my-pet bug (TT #214505).
* 10 minutes to implement * 3 hours to build (hrr) * 3 minutes to test
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/patches/0233-fix-q3textbrowser-image.diff22
-rw-r--r--debian/patches/21_qprintdialog_honour_fileprintersadded.diff11
-rw-r--r--debian/patches/series2
4 files changed, 46 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7457537..70a9b58 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,19 @@
-qt4-x11 (4.4.0-4) unstable; urgency=low
+qt4-x11 (4.4.0-4~pre1) unstable; urgency=low
+
+ +++ Changes by Sune Vuolera:
* Get patch from 4.4.2 (yes!) to fix painting of scrollbars in webkit with
some styles.
* Get patch from 4.4.2 to allow Https to be treated as https in -network.
- -- Sune Vuorela <debian@pusling.com> Wed, 11 Jun 2008 23:22:22 +0200
+ +++ Changes by Modestas Vainius:
+
+ * Add 21_qprintdialog_honour_fileprintersadded.diff patch to fix the problem
+ with QPrintDialog misdetecting some normal printers as virtual file printers
+ on dialog exec and when PrintToFile is disabled (TT #214505).
+ * Add 0233-fix-q3textbrowser-image.diff patch from qt copy.
+
+ -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 28 Jun 2008 15:31:31 +0300
qt4-x11 (4.4.0-3) unstable; urgency=low
diff --git a/debian/patches/0233-fix-q3textbrowser-image.diff b/debian/patches/0233-fix-q3textbrowser-image.diff
new file mode 100644
index 0000000..70e9bae
--- /dev/null
+++ b/debian/patches/0233-fix-q3textbrowser-image.diff
@@ -0,0 +1,22 @@
+qt-bugs@ issue : N217218
+Trolltech task ID : 217145 (Status: closed; Version fix: 4.4.2)
+applied: yes
+author: TT :) (bug reported by Laurent Montel montel@kde.org and patch provides by TT
+
+In qt4.4.x there is a regression in Q3TextBrowser it can load an image.
+
+--- a/src/qt3support/other/q3mimefactory.cpp 2008-06-25 14:30:02 -0000
++++ b/src/qt3support/other/q3mimefactory.cpp 2008-06-25 14:30:02 -0000
+
+@@ -152,9 +152,8 @@
+ QByteArray mimetype("application/octet-stream");
+ if (extensions.contains(e))
+ mimetype = extensions[e].latin1();
+- QByteArray imgfmt = QImageReader::imageFormat(abs_name);
+- if (!imgfmt.isEmpty())
+- mimetype = "image/" + imgfmt.toLower();
++ if (!QImageReader::imageFormat(abs_name).isEmpty())
++ mimetype = "application/x-qt-image";
+
+ QFile f(abs_name);
+ if (f.open(QIODevice::ReadOnly) && f.size()) {
diff --git a/debian/patches/21_qprintdialog_honour_fileprintersadded.diff b/debian/patches/21_qprintdialog_honour_fileprintersadded.diff
new file mode 100644
index 0000000..3df3beb
--- /dev/null
+++ b/debian/patches/21_qprintdialog_honour_fileprintersadded.diff
@@ -0,0 +1,11 @@
+--- a/src/gui/dialogs/qprintdialog_unix.cpp
++++ b/src/gui/dialogs/qprintdialog_unix.cpp
+@@ -749,7 +749,7 @@
+ Q_ASSERT(index != printerCount - 3); // separator
+ widget.filename->setEnabled(false);
+ widget.lOutput->setEnabled(false);
+- if (index > printerCount - 3) { // PDF or postscript
++ if (filePrintersAdded && index > printerCount - 3) { // PDF or postscript
+ widget.location->setText(QPrintDialog::tr("Local file"));
+ widget.type->setText(QPrintDialog::tr("Write %1 file").arg(index == printerCount - 2 ?
+ QString::fromLatin1("PDF") : QString::fromLatin1("Postscript")));
diff --git a/debian/patches/series b/debian/patches/series
index e164907..4c918ea 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -18,6 +18,7 @@
0227-qdatastream-regression.diff
0228-qsortfilterproxymodel-invalidate-noscroll.diff
0230-qtextcontrol-selectnextword.diff
+0233-fix-q3textbrowser-image.diff
# debian patches
01_qmake_for_debian.diff
@@ -32,6 +33,7 @@
14_add_libraries_to_gui_build_where_actually_needed.diff
15_fix_qmake_makefile_generation.diff
20_mips_atomic_ops.diff
+21_qprintdialog_honour_fileprintersadded.diff
40_alpha_ice.diff
41_disable_opengl_visibility.diff
50_kfreebsd_build_fix.diff