summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules6
4 files changed, 6 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index eebf393..30c44a2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,7 @@ qtwebkit-opensource-src (5.212.0~alpha2-1) UNRELEASED; urgency=medium
* Migrate to automatic dbgsym packages.
* Update install files for the new release.
* Update debian/rules to use CMake build system.
+ * Update to debhelper compat level 10.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 25 Aug 2017 20:50:49 +0300
diff --git a/debian/compat b/debian/compat
index ec63514..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index fef39e1..854a70e 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders: Timo Jyrinki <timo@debian.org>,
Dmitry Shachnev <mitya57@debian.org>
Build-Depends: bison,
cmake (>= 2.8.12),
- debhelper (>= 9.20160114~),
+ debhelper (>= 10.3),
flex,
gperf,
libfontconfig1-dev,
diff --git a/debian/rules b/debian/rules
index 5ebdce1..9a8d519 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,7 +22,7 @@ ifneq (,$(filter $(DEB_HOST_ARCH_CPU),ppc64el s390x))
endif
%:
- dh $@ --buildsystem=cmake --parallel --with pkgkde_symbolshelper
+ dh $@ --buildsystem=cmake --with pkgkde_symbolshelper
override_dh_auto_configure:
dh_auto_configure -- -DPORT=Qt $(EXTRA_CMAKE_ARGUMENTS)
@@ -41,8 +41,8 @@ override_dh_auto_install-arch:
override_dh_auto_install-indep:
dh_auto_build -- -CSource -fMakefile.api INSTALL_ROOT=$(CURDIR)/debian/tmp install_docs
-override_dh_install:
- dh_install --fail-missing
+override_dh_missing:
+ dh_missing --fail-missing
override_dh_auto_test:
# Do not attempt to run anything to make build-indep work