summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 6 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 9df8774..cb0068b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ override_dh_auto_configure:
qmake QT_BUILD_PARTS+=tests
override_dh_auto_build-indep:
- dh_auto_build -Smakefile -- docs
+ dh_auto_build -Smakefile -- html_docs
override_dh_auto_install-arch:
dh_auto_install
@@ -25,13 +25,15 @@ override_dh_auto_install-arch:
rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
override_dh_auto_install-indep:
- make INSTALL_ROOT=$(CURDIR)/debian/tmp install_docs
+ make INSTALL_ROOT=$(CURDIR)/debian/tmp install_html_docs
override_dh_install:
dh_install --fail-missing -X.la
-override_dh_builddeb:
- dh_builddeb -- -Zxz
+override_dh_makeshlibs:
+ dh_makeshlibs
+ # Check for private symbols not marked as such. Be verbose.
+ DEBUG=1 debian/mark_private_symbols.sh
prune-nonfree:
rm -rfv tests/benchmarks/script/sunspider/*