summaryrefslogtreecommitdiff
path: root/debian/patches/solaris-shared.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/solaris-shared.patch')
-rw-r--r--debian/patches/solaris-shared.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/solaris-shared.patch b/debian/patches/solaris-shared.patch
new file mode 100644
index 0000000..47ab57a
--- /dev/null
+++ b/debian/patches/solaris-shared.patch
@@ -0,0 +1,22 @@
+Index: zsh-new/configure.ac
+===================================================================
+--- zsh-new.orig/configure.ac 2012-02-23 21:39:30.000000000 +0000
++++ zsh-new/configure.ac 2012-05-31 23:01:56.935837293 +0000
+@@ -2689,7 +2689,8 @@
+ sysv4*|esix*) DLLDFLAGS="${DLLDFLAGS=-G $ldflags}" ;;
+ netbsd*) DLLDFLAGS="${DLLDFLAGS=${DLLDARG}-x -shared --whole-archive}" ;;
+ aix*) DLLDFLAGS="${DLLDFLAGS=-G -bexpall -lc}" ;;
+- solaris*|sysv4*|esix*) DLLDFLAGS="${DLLDFLAGS=-G}" ;;
++ solaris*) DLLDFLAGS="${DLLDFLAGS=-shared}" ;;
++ sysv4*|esix*) DLLDFLAGS="${DLLDFLAGS=-G}" ;;
+ darwin*) DLLDFLAGS="${DLLDFLAGS=-bundle -flat_namespace -undefined suppress}" ;;
+ beos*|haiku*) DLLDFLAGS="${DLLDFLAGS=-nostart}" ;;
+ openbsd*)
+@@ -2827,7 +2828,6 @@
+
+ if test "x$dynamic" = xyes; then
+ zsh_SHARED_VARIABLE([environ], [char **])
+- test "$zsh_cv_shared_environ" = yes || dynamic=no
+ if test "$ac_cv_func_tgetent" = yes; then
+ zsh_SHARED_FUNCTION([tgetent])
+ fi